WordPress MU – “wpdb::escape is deprecated”解决办法

因为现在wordpress mu的相关问题的解决办法太少了,这里只有自己找问题了,开启debug模式,又出现了下面的问题:

Notice: wpdb::escape is deprecated since version 3.6! Use wpdb::prepare() or esc_sql() instead.

 

解决办法

找到wp-content/sunrise.php(大概在12行左右)

修改为

wordpress-mu-wpdb-error

 

Mysql – mysqldump: Got error: 1016 when using LOCK TABLES解决办法

今天在备份Wordpress mu时出现:

mysqldump: Got error: 1016: Can’t open file: ‘./xxxx_wp/wp_3_postmeta.frm’ (errno: 24) when using LOCK TABLES

因为是wordpress mu所以有很多不同的表,只需要在后面添加一个–lock-tables=false就OK了!

mysqldump -u数据库用户 -p数据库密码 数据库 –lock-tables=false > 要导出的文件名称.sql

列如:

 

更新:2015年2月21日